Tables in Microsoft Word

A table consists of rows and columns of cells that you can fill with text or graphics. When you insert a table, it is displayed as a grid, each section of which is referred to as a cell. Text typed in the cells is formatted in the same way as other text. You can format the table by adding or deleting the lines around the cells and shading the background. Columns and rows can also have their width and height adjusted.

Tables are often used to organize and present information, but they can be used in a variety of other ways as well. You can use tables to align numbers in columns, and then sort and perform calculations on them. You can also use tables as a grid to assist in page layouts by arranging text and graphics.

Parts of a Table

Borders and gridlines. By default, tables have a black ½-pt, single-line, solid-line border. If you remove this border, you will still see the gridlines that form the cell boundaries in light gray. Gridlines are not printed. If you would like to turn on or off these gridlines, go to Table → Show/Hide Gridlines.

End marks. End-of-cell and end-of-row marks are nonprinting characters that, like gridlines, appear only on the screen.

Cell spacing and margins. If you are using a table to arrange text or graphics, you can add spacing between table cells. You can also add cell “padding” (spacing between the boundary of the cell and the text inside the cell) by changing the cell margin.

Nested tables. If you use a table to layout a page, and you want to use another table to present information, you can insert a nested table - a table within a table.

Table move handle and resize handle. Use the table move handle to move the table to another place on a page, and use the table resize handle to change the size of a table.
Creating Tables

1. Place the cursor where you want to create a table.
2. Click **Insert Table** on the standard toolbar.
3. Drag to select the number of rows and columns you want. When you release the mouse button, your table will appear. Don’t worry if you don’t choose the correct number of rows or columns, you can easily add additional rows and columns as outlined below.

**Navigate and Select**

You need to be able to select the cells, rows and columns you need to format your table or insert and delete rows and columns.

<table>
<thead>
<tr>
<th>To…</th>
<th>Do this…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a cell</td>
<td>Click the left edge of the cell</td>
</tr>
<tr>
<td>Select a row</td>
<td>Click to the left of the row, just outside of the table</td>
</tr>
<tr>
<td>Select a column</td>
<td>Click the column’s top gridline or border with the down-pointing arrow</td>
</tr>
<tr>
<td>Select multiple cells, rows, or columns</td>
<td>Click-and-drag across the cell, row, or column</td>
</tr>
<tr>
<td>Select the entire table</td>
<td>Click the table, then press [Alt][5] on the numeric keypad. (<em>NumLock</em> must be off)</td>
</tr>
<tr>
<td>Move to the next cell</td>
<td>Press [Tab] (When you are in the last cell of the last row, this will create an additional row)</td>
</tr>
<tr>
<td>Move to the previous cell</td>
<td>Press [Shift][Tab]</td>
</tr>
</tbody>
</table>

You can also select rows, columns, or the entire table by clicking in the table and using the **Select** commands on the **Table** menu.

**Insert Rows or Columns**

- Select the same number of rows or columns as the number of rows or columns you want to insert. Then, go to the menu bar and select **Table** → **Insert…** → and the option you want.
- To add a row at the end of a table, click the last cell of the last row and press [Tab].
- You can use **Draw Table** to draw the row or column where you want.

**Split a table**

You can enter a new line above any row in a table.

1. Position the cursor in the row above which you want the paragraph mark to appear.
2. Press [Ctrl][Shift][Enter]. When you do, Word splits your table and inserts a new blank line.
Create a Complex Table

Use the Draw Table tool to quickly create a more complex table — for example, one that contains cells of different heights or a varying number of columns per row. Using Draw Table is similar to drawing a rectangle on graph paper.

1. Click where you want to create the table.
2. Click Draw Table on the tables and borders toolbar. The pointer changes to a pencil.
3. To define the outer table boundaries, draw a rectangle. Then draw the column and row lines inside the rectangle. Hold [Ctrl] while you draw the table to automatically apply text wrapping.

4. To erase a line or block of lines, click Eraser, and then drag over the line.
5. When you finish creating the table, click a cell and start typing or insert a graphic.

Creating Tables Inside Other Tables

You can use Draw Table to create tables inside other tables, or nested tables. Nested tables are particularly useful when you use a table to layout a page and then want to use a table to present information — for example, if you use a table to lay out the Web page for your department, you might want to insert in the layout a nested table illustrating the department’s quarterly earnings.

1. Click Draw Table on the tables and borders toolbar. The pointer changes to a pencil.
2. Position the pencil in the cell where you want the nested table (or a table inside another table).
3. Draw the new table. To define the table boundaries, draw a rectangle. Then draw the column and row lines inside the rectangle.
4. When you finish creating the nested table, click a cell, and start typing or insert a graphic.

Creating Tables From Existing Information

You can convert existing paragraphs of text to a table. You can also create a table from an existing data source, such as a database or worksheet.

Convert existing text to a table

When you convert text to a table, you use separator characters to indicate where a new column should begin. Microsoft Word begins new rows at paragraph marks. If you also choose paragraph marks as your separator characters, Word converts your text into a table with one column.
1. Indicate where you want to divide text into columns by inserting the separator characters you want (tabs, paragraphs, commas, etc.).
2. Select the text you want to convert.
3. Go to Table → Convert → Text to Table.
4. Under Separate text at, click the option for the separator character you want.
5. Select any other options you want.

Insert information from another data source into an existing document

By using a query to filter, sort, and select specific fields, you can get exactly the information you want from the data source. To keep the data in your document up to date, you can create a link to the data source. Whenever the data is changed in the source file, Word can automatically update it in your document.

1. In the Word document, click where you want to insert the data.
2. Open the Database toolbar, and then click Insert Database. (To display another toolbar, go to View → Toolbars. Choose the toolbar of your choice.)
3. Click Get Data.
   - If you want to use Word features to retrieve, sort, and filter the data: select a data source, click Open, and then continue on to step 5.
   - If you want to use Microsoft Query to retrieve, sort, and filter the data: click MS Query, construct your query, and then skip ahead to step 6.
4. Click Query Options, select the criteria you want, and then click OK.
   - To customize the Word table formatting, click Table AutoFormat, select the options you want, and then click OK.
5. Click Insert Data.
6. Under Insert Records, select the records to include in the Word table.
   - If you want to be able to update the data in the Word table when the source data changes, select the Insert data as field check box.
7. Word inserts the data in the Word table as a DATABASE field, which is linked to the source data. To update the field, click in the table and press [F9].

Converting tables to text

Text within a table can be converted back to normal text by going to Table → Convert → Table to Text, if for instance you decide that a table format is not the best layout for the text.

Formatting Tables

Resize Cell, Rows, Columns and Tables

Resize a table

1. Rest the pointer on the table until the table resize handle appears on the lower-right corner of the table.
2. Move the pointer to the resize handle until a double-headed resizing arrow appears then drag the table boundary until the table is the size you want.
Microsoft Word Tables

Change the column width in a table
Rest the pointer on the column boundary you want to move until it becomes a two-headed arrow \( \text{→} \), and then click-and-drag the boundary until the column is the width you want.

Change column width to a specific measurement:
1. Click a cell in the column.
2. Go to Table → Table Properties, and then click the Column tab.
3. Choose the options you want.

Make columns automatically fit the contents:
1. Click a table, and then go to Table → AutoFit → AutoFit to Contents.

Display column width measurements:
1. Click a cell and then hold [Alt] as you drag the markers on the ruler.

Make multiple rows or columns the same size
1. Select the columns or rows you want to make the same size.
2. Go to Tools → AutoFit → Distribute Columns Evenly or Distribute Rows Evenly.

Change the row height in a table
Rest the pointer on the row boundary you want to move until it becomes a two-headed arrow \( \text{→} \), and then drag the boundary.

Change row height to a specific measurement:
1. Click a cell in the row.
2. Go to Table → Table Properties.
3. On the Row tab, select the options you want.

Display row height measurements:
1. Place the cursor in your table so the table borders are visible on the ruler bar.
2. Hold [Alt] as you drag the markers on the ruler.

Make multiple rows or columns the same size
1. Select the columns or rows you want to make the same size.
2. Go to Tools → AutoFit → Distribute Columns Evenly or Distribute Rows Evenly.

Change the space between cells in a table
1. Click the table.
2. Go to Table → Table Properties.
3. On the Table tab, click Options.
4. Under Default cell spacing, select the Allow spacing between cells check box and enter the measurement you want.

Table AutoFormat
Enhance your table by adding borders and filling cells with colors, patterns, or shading. You can also use the Table AutoFormat command to quickly give your table a polished design. Save time by using the Table AutoFormat to format your table for you. You have many selections from simple, accounting to colorful. Once you have applied a table format, you can still change individual parts of the table to suit your need.
1. Select your table
2. Go to Table ➔ Table AutoFormat…
3. From the Formats list, select the style you want. As you click on a style, the preview area will show you what it will look like.
4. You can modify what formats will be applied by selecting Borders, Shading, Font, Color, or Autofit (this will resize the columns and rows to fit the largest entry).
5. Choose if any special formatting will be applied to the Heading rows, Last row, First column or Last column.
6. Click OK to apply the format.
7. If decide to remove all formatting, return to Table ➔ Table AutoFormat… and select (none) from the Formats list then click OK.

**Borders and Shading**

When you insert a table in Word, it automatically adds a border around the cells in the table. For many purposes, you may not want the borders or you may want to change them.

To get rid of the borders, simply press [Ctrl][Alt][U] right after inserting the table. After you insert the table, the insertion point is typically within a cell of the table. If it is not, you should make sure you place the insertion point within the table before pressing [Ctrl][Alt][U].

To change the border and/or shading for a cell, group of cells or the entire table:
1. Select the cells, rows or columns you want. (If you don’t select, Word will assume you are formatting the entire table.)
2. Go to Format ➔ Borders and Shading… Select the Border, Page Border or Shading tab to make the changes you want.
   - Border - Change the settings, style, color, width and what area of the table to apply the changes to.
   - Page Border - Add a border to the page.
   - Shading – Change the fill color, pattern and which area of the table to apply the changes to.

**Changing the Position of Text in a Table**

**Text Direction**

By default, Microsoft Word aligns text horizontally in table cells, callouts, text boxes, or AutoShapes. You can change the text orientation so that the text is displayed vertically.

1. Right-click the cell(s) to change and select Text Direction…
2. Choose the Direction option you want and click OK.
**Microsoft Word Tables**

**Questions?**
UNL Shared Computing Services  Call 2-0585 for assistance

---

**Cell Alignment**
By default, Word aligns text in a table to the upper left of a cell. You can change the alignment of text in a cell — both the vertical alignment (top, center, or bottom) and the horizontal alignment (left, center, or right).

1. Right-click the cell(s) to change and select **Cell Alignment**…
2. Choose the alignment option you want.

### Horizontal Alignment
<table>
<thead>
<tr>
<th>Left</th>
<th>Center</th>
<th>Right</th>
</tr>
</thead>
</table>

### Vertical Alignment
<table>
<thead>
<tr>
<th>Top</th>
<th>Center</th>
<th>Bottom</th>
</tr>
</thead>
</table>

---

**Working with Long Tables**
When you work with a very long table, it must be divided wherever a page break occurs. You can make adjustments to the table to make sure that the information appears as you want it to when the table spans multiple pages.

**Repeat Headings on Every Page**
If your table has a heading row, you can make the heading automatically appear at the top of each page.

1. Place your cursor in the table.
2. Go to **Table ➔ Heading Rows Repeat**.

**Control Where the Table is Divided**
By default, if a page break occurs within a large row, Word allows a page break to divide the row between the two pages. You can prevent a table row from breaking across pages. You can also force the table to break across pages at a particular place.

### Prevent a table row from breaking across pages
1. Click the table.
2. Go to **Table ➔ Table Properties**, and then click the **Row** tab.
3. Clear the **Allow row to break across pages** check box.

### Break a table across pages
1. Click the row you want to appear on the next page.
2. Press [Ctrl][Enter] for a page break.

---

**Using Tables as Spreadsheets**
You can use tables to perform some of the tasks you might use a spreadsheet for — for example, you can sort table entries in alphabetical, numeric, or date order. You can also total a row or column of numbers in a table, as well as perform other calculations, such as averaging.
**Sort Table Entries**

1. Select the list or table you want to sort.
2. Go to Table → Sort.
3. Select the sort options you want.

To sort a specific column or cell:
1. Select the column or cells you want to sort.
2. Go to Table → Sort.
3. Select the sort options you want.
4. Click Options.
5. Select the Sort column only check box.

**Total a Row or Column of Numbers**

Microsoft Word is a word processing program. It is designed to incorporate only a few of the features of spreadsheets. If your column or row contains blank cells, Word will not total the entire column or row. You must type a zero in each blank cell to total the entire row or column. If you need to do complex formulas, use Microsoft Excel and copy or link the table into Word.

To quickly total a row or column of numbers, click the cell where you want the sum, and then click AutoSum on the Tables and Borders toolbar.

If you change the referenced cells, you can update the calculation by selecting the cell(s) with the formula and then press [F9].

**Note:** If you see codes between braces — for example, {=SUM(LEFT)} — instead of the actual sum, Word is displaying field codes. To display the results, press [Shift][F9].

**Other Calculations**

1. Click the cell in which you want the result to appear.
2. Go to Table → Formula.
3. If Word proposes a formula that you do not want to use, delete it from the Formula box.
4. In the Paste function field, click a function.
5. To reference the contents of a table cell, type the cell references in the parentheses in the formula. For instance, to add the numbers in cells A1 and B4, the formula would read =SUM(a1,b4)
6. In the Number format field, enter a format for the numbers. For example, to display the numbers as a decimal percentage, click 0.00%.

**Note:** Word inserts the result of the calculation as a field in the cell you selected. If you change the referenced cells, you can update the calculation by selecting the field and then press [F9] or right-click and select Update Field.
Using Tables to Create Page Layouts

You can use tables to create page layouts, such as side-by-side paragraphs in a résumé, or to create text, graphics, and nested tables on a Web page.

Tables can be used for displaying information in an easy-to-read format or you can use a table as a grid for laying out your document.